DynaShape

Ah that node requires the latest version of DynaShape. Please check the updated installer.

You can also set up this simulation without that node, but it will takes some work

1 Like


works perfectly with rvt2019/dynamo2.0.1/dynashape0.5.1.1:pray:
let’s play…

Thanks for the good comments that I recommend. I know a lot more.:ta บอลออนไลน์
คาสิโนออนไลน์
UFABET

hi
I try to set family with 4 adaptive points
but ı cant
ıt set a family every point
what ı missed

please help me

Hi @LongNguyen, I think it’s better to continue on this thresd… So… I successfully installed it on my laptop running Dynamo 1.3 and it was successful. However, after running Dynamo, I get this:

Any ideas?

hi @LongNguyen
i have below problem on installation

image
Dynamo Version :
image

Please check the download link again, I just put the package there in the “Manual Setup” folder, you can just unrar and place the copy the _DynaShape folder to the Dynamo custom package directory.

You don’t have to use the installer, I will eventually remove it since it is no longer needed in Dynamo 2

Hello, @LongNguyen , so we finally installed dynashape and starting to run the sample files. we are getting a lot of errors off the bat. see below. is there nodes that we have to install first to get this thing going?

Hi. Have you installed the MeshToolkit package?

Thanks for the prompt reply ! just did right now. but still same problem. see screen capture below

@LongNguyen, Do you have a list of nodes / custom nodes that we can use as checklist to ensure all relevant nodes are onboard?

@LongNguyen , Resolved! we had to restart dynamo for the mesh tool to be recognized , not just the example file reload. Baby steps . but beginning to play with the sample files. thanks @LongNguyen

@LongNguyen, do you provide online instructions on dynashape ? or are there step by step youtube videos of your 12 examples ?

Thanks

arman

post from Feb 17 2019:

hi @LongNguyen , i recently upgraded to revit 2019 and dynamo 2.02. After installing dynashape, most of your example files are giving error messages. I see a lot of previous posts are talking of the same issue. see screen capture below which shows the constant’s vector value as you had instructed before, but I am still getting errors. any suggestion to resolve this problem ?

2 Likes

Dear Long,

Firstly like to say Dynashape is a fantastic set of nodes and I have enjoyed developing knowledge of its basic application, I am however looking to push it a little further.

My query how would you go about creating a conical tensile membrane as exemplified in the below image, I understand using point anchors however can we select a circle/points representing a circle as an anchors, I appreciate any response in advance.

@LongNguyen, I’m the QA manager for Autodesk Alias, which has an integration of Dynamo. We are now on Dynamo 2.0, but your installer doesn’t accept our folder structure when the folder for the version is named 2. I also tried renaming to 2.0, v2, and v2.0, but none of those worked. It works fine when the folder is renamed to 1.3.
Can you let me know what version string your installer expects for Dynamo 2.0 (if that works at all)?

Hi Micheal

The string value that the installer looks or is “2.0”. So it is a bit strange that it did not work for you.

You can just download the package here and just manually place it in the Dynamo packages directory. Remeber to keep the underscroll “_” chactacter at the beginning of the package name (i.e. “_DynaShape”) and do not forget to install MeshToolkit package as well

https://drive.google.com/open?id=1VePNT7fFl5Ti_dO08yVvm7x2CyJJsSkt

I will eventaully deprecate the installer anyway as it is not longer needed, because the Dynamo package manager now supports installation of ViewExtension file already

Let me know if it works for you.

Bests

Long

1 Like

Hi Long,

i cannot install the package in both of the ways (manual and installer).

I tried to open the sample files, seems that DynaShape.dll location of the nodes are calling on your computer folder and I cannot find a way to change the location
image

can you advise any way to solve this issue? thanks

Dickson

Hello tllai. Can you check if you have installed the MeshToolkit package (and the restart Dynamo) ?

This is mostly a problem of mesh creation. Currently the meshing tool in Dynamo is a bit lacking. The easiest way is to use another software (3ds Max, Maya) to generate a well triangulated mesh with the circular opening. Then you can read the mesh into Dynamo, extract the edges and use them to construct the Length goals.

Amazing script Dynashape!.

Will be it avalaible for Dynamo in Civil3D 2020? I have tried it but it is not working.

Dynamo gives an error in the node Goals.ConstantGoal_Change

image

I have not test it in Civil3D but I believe it should work.

First, please make sure you have installed MeshToolkit package for Dynamo in Civil3D

And for that node. Please try plugging in a value 1.0 to the “weight” input. There should be a default value there for that input but for some reason that does not work on some computers

1 Like