Nice script. I was not even aware that know Dynamo has GaussianCurvature node out of the box. Will play with the file later this afternoon :slight_smile:


Could you please help me to resolve this problem ?


Hi, seems like there is no Dynamo folder located inside your computer’s AppData.

Can you please help me check by going to “Dynamo Main Menu > Packages > Manage Packages …”. Then click on the triple-dot icon/button on any package of you have installed an select Show Root Directory…

An explorer window will pop up. Click on the address bar so that the full path is showed. Can you please share the screenshot with me, like below:


Pls have a look at the below image.


@Zach_Kron: I tried your script with around 400 panels and it seemed to work fine :slight_smile:

I did notice, however, the solver tends to flatten the sphere into pancake if momentum is set to True and ShapeMatching weight is too high

  • Generally momentum is good for physical motion simulation (like in the cloth simulation example), and in many cases, it helps the geometric optimization reaches the solution in fewer iteration. But in other cases, it can lead to unstable and counter-intuitive result. So generally, for geometry optimization, I tend to turn it off.

  • The system in your script is obviously over-contrainted. The ShapeMatching goals are conflicting with the CoPlanar goals. In such case, we can mediate them by adjusting their weights (relative to the others). In the screenshot below I changed the ShapeMatching matching weight from 1.0 (default) to 0.2, this allows the the quads to achieve better planarity, at the cost of larger deviation from their original shapes


Excellent, thanks. What is the difference between setting the weight initially in the .Create node versus with the .Change?


The .Change nodes allow the goal parameters to be dynamically adjusted while the solver is running.

If you change parameters in the .Create nodes, they will only have effect after the solver has been reset.

I would like to combine the Create and Change nodes into one, but currently the ZeroTouch plugin framework does not make easy to do so.


Hi @LongNguyen

I have only one issue I follow the instruction but still can’t control the points through the mouse even in the background 3D view, can you please help !. please check the picture below. and Great work man (Love these nodes).


Hi Mohammad. Just a quick reply for now. I will look into this when I can. It never happened to me personally but at least one other user has reported this.

If possible, can you please try this on another computer?



i have the same problem till now !


and here is a screenshot as you requested from my computer


Hi Long,

Great work! I’ve had some fun playing with it already.

A general question: does anyone know how to model pressure rather than a static force like gravity?

For modelling air-supported structures in Revit. :grin:

My guess is a vector force applied to a facet or vertex, but how to calculate that force is a bit beyond me… my high school physics was a long time ago!


Sorry for late reply, I am currently on vacation.

Generally, simulating pressure is just a matter of applying force on the the nodes along the normal direction. The slightly tricky bit is that the normal direction changes as the object undergoes motion, Because of this, we will need to implement a custom goal for this, rather than just use the “constant goal” that have already been in the package.

This is conceptually simple but will take a bit of works to code it up. I have added it to my to-do-list. Currently my main priorities are to make the tool more stable and improving the display/feedback


Hey !

First of all, thanks for your work and community enhancment !
I’m sorry to annoy with kind of a very basic issue, but I can’t even install your package (downloaded throught google drive).

Here’s the issue, saying Access to ‘DynaShape.dll’ is forbidden. I tried administrator mode, resulting the same issue… I think I’m missing a very simple thing or maybe a step into dowloadin and install process.
Any Idea so I can install and enjoy this beauty ?

Thx Guys


@Matthieu_Brossette1 try something like this: https://stackoverflow.com/questions/3072359/unblocking-a-dll-on-a-company-machine-how


Thanks @Michael_Kirschner2 for help, I tried these one and still unable to install. But I’m gonna try @john_pierson way and rebuild package from source. I’ll also try with another computer… It could be the firm one that block the install…


This is great. Exactly what I was looking for. I will definitely be trying this out in the near future. Thanks for all your work on this @LongNguyen .


And finally solved my installation issues… Here is my first steps with this amazing package ! Thanks @LongNguyen !

Let’s try to bake it as Revit shape !


@LongNguyen I would like to share how I solved problem I had installing Dynashape. I have two path for my packages in Dynamo, the main one is a shared storage (firm server), the second one is my local folder (appdata, roaming, etc). We work this way so everybody is up to date with their Dynamo setup. But Dynashape goes directly in the local folder and, for an unknown reason, do not show up if i don’t set this local folder as main storage for packages… Can’t find exactly why it act like this, but just wanted to let you know. Cheers !


Hi Matthieu.

First, very nice example! You can already generating Dynamo geometries from DynaShape (see post 18 and 19 by Zach Kron) and use them to place Revit family instances.

I am glad you have figured out the installation problem. The installer I made assums that the main package storage folder is in appdata/roaming folder. I did not really foresee the scenario where it could be located on the shared storage. In the next version I will probably release a manual install package with manual instructions (in addition to the installer) for cases like this.

Anyway, in the future when they default Dynamo Package Manager supports packages that use the ViewExtension feature (which is needed for the mouse manipulation), we wont need an installer or manual setup anymore