DynaShape

Just wanted to thank you for your help @LongNguyen - think my VPN was having a bad day which is why the link was timing out :roll_eyes:. I can confirm that the version of 7.3.0 for 2.7 or newer shows up in the interface for Dynamo for Revit 2022 and for Sandbox 2.11.

Many thanks

1 Like

Hello, I have downloaded the the variant for .7 or newer but it still doesn’t show up in my Dynamo for Revit… It is 2.10 on Revit 2022. Do you have any recommendations?

Did you unzip it with 7zip or with the tool built into windows? If the later you will need to right click each dll, open for properties, and unblock it.

2 Likes

That worked! Thanks a lot

Can someone share DynaShape for Revit 2022 again, please?

the dl link is in the first post of the thread DynaShape

2 Likes

Hi all

I have successfully installed the Dynashape package, and the Dynashape solver works as intended. However, when I try running the Dynaspace engine, all the bubbles are stationary and do not allow for manipulation even when the “enable manipulation” boolean input is on.
I am using Revit 2023. Could this be a compatibility issue?
Thanks for your help in advance. @LongNguyen @JacobSmall

You also need to set Reset to False to (When Reset is true, the while animation is always stay at the initial state) :slight_smile:

Thanks for the response.
I also did that but it did not work.

One thing I forgot to mention. You also need to disconnect the SilentModeSettings and leave it empty. Otherwise the animation will always run in “silent mode” (i.e. non-interactive mode)

2 Likes

Thanks so much. That was it!
Thanks for all the work on this great package.

Hello,

I am testing the DynaShape package that I downloaded from: Space planning in Dynamo with DynaSpace - Dynamo BIM
I made the script based on the example from the same site. I am currently using Revit 2020 with Dynamo 2.3.0
I changed just excel input data.

Below you can find both files:
DynaSpace_Example.dyn (126.0 KB)
SampleBuildingProgram-Apartment.xlsx (10.2 KB)
I encountered two problems:

  • I would like to evaluate the adjacency score using SpaceAdjErrors data. Instead of numbers, I get lines…I do not understand why…What I should adjust to get the correct values?

  • I cannot manipulate the centre points of bubbles. I set Reset to False and Execute to False (I also tried Reset to False and Execute to True), and it doesn’t work. I can only manipulate container points. What should I adjust?

I would be happy if you could help me:)

Best regards,

Julia

Hi @Julia_Ratajczak ,

In addition to Reset = False and Execute = True, please make sure that:

  • Manipulate = True
  • The silentModeSettings input should be empty (disconnected).
1 Like

Thank you very much for your reply!
Great, it works:)
Could you please tell me if SpaceAdjErrors can be still used to evaluate the adjacency? I saw in a tutorial it was used, but maybe something has changed in a new version of DynaSpace…

May I also ask you kindly how I should set up the settings to keep all bubbles within the container? Now, when I move bubbles, they go outside…There are also a few red points (without bubbles) which are moving together with bubbles. I do not know why they are active.
I guess I should play around with settings. Is there any recommendation to set up the range of parameters (e.g. spaceAdjacencyStrength, Boundary strength, etc.)?

Many thanks for your support!

Best regards,

Julia

Thank you very much for your previous reply.
Sorry for bothering you again with another issue.

I am testing DynaSpace, and I encountered another problem.

From Excel, I imported room names and their area. Based on this input area, the bubbles are displayed. I noticed that the bubble size and room name do not correspond. The order of circles in the list from the Dynamo solver (Engine.Execute) is mixed up. If compared to the list in Excel.

Have you any idea how I could solve it?

Best regards,

Julia

SpaceAdjErrors seems to be working fine on my computer. Can you please try to download DynaShape 0.8.0 just published on the package manager to see if it fixes the proble (Its a good a idea to manually remove the current DynaShape on your computer before installing the one from the package manager to avoid any potential conflict)

1 Like

About the name and area being mixed up. Can you give me a screenshot with the previous node as well?

Thank you for your reply.

I solved the problem, however, I am not sure if it is the most efficient way.
I reordered the items from the DynsSpace solver based on Excel’s list order.
The output from Engine.Execute mixed up values of items: 1,2,3,4,5,7,8. I replaced values of item 1 with 2, 2 with 4, 3 with 5, 4 with 1 , 5 with 3, 7 with 8, 8 with 7.

Maybe it is a problem with my Excel…

BR,

Julia

When you run the sample file, does it produce the correct order on your computer?

Hi,
I used the sample file in my script and it works, the list order is correct. It means that something wrong is with my Excel file…I copied the content from my Excel file to the sample file, and it still gives me the wrong order…So strange…So far as you know, is there something to set up in Excel?