Dynamo Issue i can not run my scripts and this warning keeps coming up

did you make this graph in an earlier version of dynamo?
then after the upgrade are you trying to reuse your old graph?

Hi Erik,

the graph supported by you thank for your help on that by the way, I had had dynamo 2.0 at the time however when I ran the graph it didn’t work for me, so I then upgraded by dynamo from 2.0 to 2.1 which is the current version I believe I then also reinstalled the latest Orchid package as you had added new and updated nodes to support the graph if you remember before the new year.

however it still doesn’t work for me only errors unfortunately

I am afraid you have hit a well-known problem in the Dynamo 2.0.x versions… There a solution says @Michael_Kirschner2, but I have no idea when this solution is going to be released.

I think the only solution for now is to delete the nodes and reinsert them… or if you have it as a dynamo 1.3.x graph, then use that. Graphs in 1.3.x will upgrade correctly :slight_smile:

You can follow the error here…

so the plan of action for this is to reinstall Dynamo 1.3 version and download the graph again and take it from there hopefully fingers crossed this this work.

Erik, which version of dynamo do you used ?

I have 1.3.4 and 2.0.2 installed, and I do only test if a graph can migrate from 1.3.x to 2.0.x. Since you only can have one version of the 1.3.x range and one version of the 2.0.x range installed at the time, then I have the latest versions. I have therefore no options for testing things between internal versions.

That limits me by now to not optimize my package moving nodes around or changing namespaces. This is a problem for me since my package is growing very much these days. I have coded a lot of new nodes and I see that I need to refactor where nodes are placed to keep a usable overview of the nodes in the package for the users. Until there is a solution will I therefore not do this work. But before I realized the problem have I moved 20+ nodes around… these nodes are now giving users a rising number of problems :-S

By the way… a graph made in Dynamo 2.0.x cannot be open in Dynamo 1.3.0, only the other way around!

I have a better understanding now of this issue I have been struggling to understand for the last couple of months why the graph wasn’t working however for the graph to work I would need to download the version of dynamo you had to make the graph and download the graph again from the forum and see if its works?

I cant say exactly what goes wrong but it is also the package authors fail.
If we (I have done it) move nodes in our packages or rename nodes but build the required migration, then that simply doesn’t work internally in Dynamo 2.0. In other words, it is not only the dynamo team which is failing here… we all are :-S

No thank you you guys do a enough really appreciate it, so if this is the case is there a way were I can use a text file and import them into my families in a batch format using nodes that wont show errors maybe can I still achieve the what I want through another way or graph?

I don’t have an example to do that yet, but it should be doable…
this is how to do it in a 1.3 graph, it is more of less the same procedure in 2.0…

Try to see this proof of concept for solving the issue…