Dissable Steel Framing Auto-Miter?


#1

Does anyone have a workaround for disabling the auto-miter for placement of coplanar members that share a node and the same family symbol?

I couldn’t find any reference to this joint feature via API and the only solution I currently have (aside from changing the families structural material behavior) is to organize the curves so I can map coplanar elements that share a node to independent families which does breaks the miter but then I have to rerun the definition mapping to the correct size.

It seems like there should be a better solution, what am I missing?

Thanks in advance,

Jeff S.

 

Auto-Miter


#2

Hi Jeff,

I believe these are the API calls you’re looking for:

http://revitapisearch.com/html/2ff87911-3c17-babc-781d-e2c68e62d4e9.htm

http://revitapisearch.com/html/02355f63-69e9-ae86-31bf-c42c18beef46.htm

Here’s a really good guide on their use:


#3

Revit auto-mitering strikes again! The only way to deal with this completely is to disable auto-mitering in your family. You need to edit the family such that the solid extents of the framing extrusion are not locked to the “member left” and “member right” planes, which are used to calculate miter, but are locked to the “left” and “right” planes. This will prevent Revit from attempting to miter your structural framing.