Deprecate/remove old packages


#1

how can I deprecate/remove old packages?

I have updated my little package several times, but didnt deprecate the old ones, and now i want to get rid of them.


#2

Currently, you cannot remove packages from the package manager, this isn’t a limitation of the package manager but a design decision, you may deprecate packages through the UI I believe.

The reasoning for not being able to remove them is that other packages, and others works may depend on them, if your old package suddenly disappears then their graphs and packages will no longer function. If you have a new package that you’d like users to migrate to, you can deprecate the old package and include that in the description.

A good place for suggestions to the package manager are on the github issues site.