Custom packages are not showing up, even if correctly installed

Hi all,
recently I’ve moved the whole company library from a server to a cloud service. I’ve changed correctly all the settings of the directory path and customized a DynamoSetting.xml file in order to point a specific folder. Everything worked, till the “moving” to this cloud service.

Anyway if I click on Packages > Manage Packages… everything seems to be right, but as you can notice in the image below, the Manage Packages window is showing correctly all packages, while Dynamo it is not. :confused:

Looking at the image, you can see just few packages are showing in the Dynamo library, like DataShapes, Steam, etc…

I don’t know what else to do to solve the issue…

The only setting that is changed during the “move” is the cloud service, specifically G Drive.

Any help or advice is more than welcome. Thanks.

Hi @Ernesto_Pellegrino

Similar issue was discussed here:


In addition to what @kulkul said, f you look at the DLLs for the packages are the able to be unblocked? Right Click > Unblock


Thanks @Kulkul I’ve tried it but it is showing me an error probably of the path :confused:

I will try to unblock all the DLLs as @john_pierson wrote, and try again. I’ll let you know.

Thanks guys, have a nice BIM weekend! :slight_smile:

I have deprecated the “DanEDU Dynamo” package. It is replaced with the Orchid package.

Your Lunchbox package is old… try to remove this package and see if you get the other packages …and search for packages that has the “DynamoServices.dll” installed… this might give you errors.

1 Like

thanks @erfajo for your reply, I’ve installed your orchid package correctly with the instruction provided.

Anyway, I couldn’t solve the problem, I tried all of your advices but no one did work.

After all, I found an “homemade” solution to this problem and maybe could be useful to someone else too, in future.

  1. Switch from G drive to Microsoft Onedrive (which is also a bit cheaper btw);
  2. Click on Start and type “partition”, hit enter, you will see the disk management window;
  3. Right click on any disk where you have enought space, and select Shrink Volume…;
  4. You will see a wizard window appear, complete the procedure chosing how much space you will “give” to that new drive;
  5. Right click on the new volume just created and select New simple volume;
  6. If you’ve already installed Onedrive, select the Onedrive folder, then on the Home tab, click on Move to…;
  7. If you need to install Onedrive, just select the new drive during the installation;

After all of that, I’ve customized the DynamoSetting.xml file in order to point a specific folder on Onedrive which contains all of the packages and definitions and it did work. That was a really huge problem to solve for me because I need that 25 PCs, divided in different offices both in Italy and abroad, to use the same scripts and libraries.

That’s how I solved the issue, and it is working really nice. Probably there are lots of better solutions out there, but I am fine (I hope) for the next 20 years, I’m terrified by the idea of ​​re-configuring everything again. :scream: :scream: :scream:

have a great day, :slight_smile:

I tried creating a local and online custom package. Had some edited nodes from other packages in it. Installed to the 1.3 package folder on the server where all packages are. The nodes come up when searching but the package dosnt show in the left menu :thinking:

This conversation is quite old, but I am facing the same problem with a custom library I wrote.
So the library is installed but doesn’t show up on the sidebar.
If I load manually the DLL, will show up.
Any idea why this happens?
I am using DynamoSandbox 2.12 and the node are written using ZeroTouchLibrary., so it should be a version problem.