Creating a color legend from View filters

Just a litle add, my program must be run two time.
Fisrt time it create filledregion with correct color
And second time it create filledregion in view legend

It’s working for me but, why it doesn’t sort the filled regions in alphabetical order?


I have some issues with the Dynamo.
I tried tu use Daniel’s solution but I don’t find “FilledRegionColorChange” in Plisken’s package or “FilledRegion Color Change” from Loci’s package.

I didn’t find either “View Get Color Or Filter” so I tried to replace it with “Get Filter Overrides”.

Dynamo is still new for me so if someone could help me, I’ll be really thankfull.

Hi @gi.cobigo,

Welcome to the Dynamo Forum.
I upgraded the nodes of the Genius Loci package during these 2 years.
Use the Get Filter Overrides and FilledRegion Properties Change nodes instead.

Create a color legend from View filters.dyn (51.2 KB)

Hello Alban,
Thank you for your reply but it doesn’t work on my side…

I have several options that can explain that :

1 - Because of the version of Archi-lab and Loci (I have the latest for both of them)
2 - In “View with filter” I choose my view but this one has a “Gabarit”. Does it only work when there is not one activated on several views?
3 - In “Filled region Type to choose” I choose one of the filter so there is only one color that appear in my legend (and no text to explain what this colour is about). Did I use properly your Dynamo?

With all that I have two boxes in yellow : “Duplicate” from Archilab and “FilledRegion By curve”.

Do you know why is this not working?

I put my Dynamo, my filter and what I see in the legend when I run the Dynamo.

Thank you very much.


Hi Gilles,

The explanation is simple. Dynamo can’t handle nulls ​​in the first position. There is inevitably an error.

But luckily it’s quite easy to filter the nulls :

Create a color legend from View filters.dyn (57.3 KB)

Sorry but it doesn’t work for me…

Do I have to do something else than just run the Dyn you sent to me (after choosing the view and the legend of course)?

I have simplified my test with only one filter in my view “Fourreaux BT”. I have an issue in the noeud “archilab_ElementTypes.Duplicate” and I think that’s what cause an other issue in “FilledRegion.ByCurves”.

Maybe the problem come from my version of archilab (version 2021.25.17). I have uninstall then re-install it but it doesn’t work better.

I hope you could help me. Contact me on Linkedin (Gilles COBIGO) if you have the time for me, speak in french may be easyer to solve my problem :slight_smile:

You can try instead the ElementType.Duplicate in Springs package or the OOTB node in Revit 2021.

You can also try with a different filledregion type.

Yes it works :slight_smile:

I change with your second proposal of noeud.

Thank you very much Alban for your time and patience !

Hello People,

Any idea why my Filled.region.Bycurces node throwing error : ***One or more of the input types do not match. No version of Bycurves

hello friends thanks for sharing your knowledge,
I have an error, I do not get the names of the filters in the legend. help

hello friends thanks for sharing your knowledge,
I have an error, I do not get the names of the filters in the legend. help


It’s not possible to help you without seeing your graph with all the previews enabled under the nodes.


You should watch the post : Creating a color legend from View filters - #35 by Alban_de_Chasteigner
So far you only get one color :

You can create texts with the TextNote.ByLocation node.

Hi every body,
I come back with correction to this script.
Revit 2022 and Dynamo 2.12 - Windows 11
I have just a litle problem with TAG and offset.
No synchro

1 Like

Hi! I saw these post ( i think i read it all) and it worked BUT i only got one color.
I saw that it was suggested that could do a change of region type and the node i already used the OOTB node.

Although that…It still appears one color.
Do you know what i can change?

Thank you!!



Did you try to set the last node at longest lacing?


Hi! Ups, I forgot that (better, i didn’t even notice that in the code)
Problem solved!

Many, many Thanks!

1 Like