Crash with SharpDX and Helix ...?

Hi

this is my first post here. At the moment I don’t have any idea of Dynamo - just started the Player and tried to open the basic-samples.

Yesterday I tried it with Win 10 plus Revit 2017 and 2018 and Dynamo 1.2 - when I opened some “basic samples”, Dynamo crashes with this message:

SharpDX.SharpDXException: HRESULT: [0x887A0005], Module: [SharpDX.DXGI], ApiCode: [DXGI_ERROR_DEVICE_REMOVED/DeviceRemoved], Message: Die GPU-Geräteinstanz wurde angehalten. Verwenden Sie GetDeviceRemovedReason, um die erforderliche Aktion zu bestimmen.

   bei SharpDX.Result.CheckError()
   bei SharpDX.Direct3D11.Device.CreateBuffer(BufferDescription& descRef, Nullable`1 initialDataRef, Buffer bufferOut)
   bei SharpDX.Direct3D11.Buffer..ctor(Device device, DataStream data, BufferDescription description)
   bei HelixToolkit.Wpf.SharpDX.RenderUtil.CreateBuffer[T](Device device, BindFlags flags, Int32 sizeofT, T[] range)
   bei HelixToolkit.Wpf.SharpDX.LineGeometryModel3D.Attach(IRenderHost host)
   bei Dynamo.Wpf.ViewModels.Watch3D.DynamoLineGeometryModel3D.Attach(IRenderHost host)
   bei HelixToolkit.Wpf.SharpDX.Viewport3DX.HelixToolkit.Wpf.SharpDX.IRenderer.Attach(IRenderHost host)
   bei HelixToolkit.Wpf.SharpDX.DPFCanvas.Render()
   bei HelixToolkit.Wpf.SharpDX.DPFCanvas.UpdateAndRender()

Now I downloaded and installed Dynamo 1.3 - it just does not crash, but it displays the same message in some of the “blocks”.

The forum at “helix.toolkit” says "maybe old helix version"

So any simple solutions for a simple beginner?

Thanks and regards

Peter

The current update (Revit 2018 + Dynamo 1.3.1) works fine. :grinning:

Have you tried with revit 2017?