Changing Values of Different Parameters

Hello All,

I have got a problem, I hope I can get some help.
I want to change values of different parameters at the same time and export images.
for example; In each exported image, I want to see that dimensions of all parameters have been changed simultaneously.

It may seem a simple problem but it turned to a big challenge for me, as I can not get the results.

I appreciate your help and suggestions. Thanks.

Here are the files;

Hi Rana,

@Raha_R what does the error says at “Change Parameter and export image” node?

Hi @Kulkul,

It doesn’t give an error but all the exported images are the same and it doesn’t make any changes.

Actually, it could be run for parameters from one element, but when I select more than one elements, it doesn’t work.
something wrong with the way I used nodes?

Any suggestion please?

@Raha_R Try changing to “longest or cross product”.

@Kulkul I changed lacing and tried with both Longest and Cross Product. But no changes applied…

@Raha_R Where are the parameters in your family?

@Kulkul actually I have been thinking all the time that my parameters are those appeared in the dimension tab! You mean that, it was a mistake?

I defined the parameters in “add parameters” while creating the parametric families… I checked some tutorials but didn’t recognize any other specification have to set up.

P.S. parameters are for different elements and families. But I didn’t set them to each element separately and put all of them in one list. Is that wrong approach? In such a case how could be solved?

@Michael_Kirschner created the node initially. Some clues on behalf of him could greatly help.

hi @Raha_R I don’t remember exactly how this node is implemented - if it works for a single family instance but not for multiple, then you can map the custom node with parameters names and values set over the list of elements.

I would open up the node and see if the parameter set call is mapped over the list of elements or just applied to one?

Where did you get this this node btw?

Hello @Michael_Kirschner Thanks for your response. Actually, I tried to map it with parameter’s value but I really don’t know where is the problem with my scripts .
I can not find the thread now, it was initially expanded in a post previously.

@Michael_Kirschner I think she found the node from here

@Raha_R See if this topic helps

1 Like

Thank you @Kulkul, I checked them before. I doubt if “select model elements” could work here properly or maybe the issue is related to somewhere else like the way I used map…

@Michael_Kirschner please see this one too (where I saw your workflow first);