Change View Parameter error "Read Only"

Hi All

I am having a issues when i am trying to change a instance parameter for a view and it keeps coming up with "Read Only issues. for the life of me i have no idea why this isn’t working…

the reason why i am doing this is because I want to make sure all the revit users are using element keynotes, and i want to push into the view a value/note noting the user to check that view for user keynotes and change them to element keynote. this can be used with the Rythem package… ( youtube flix.

Many thank cheers

Keynote_UserVSElement.dyn (19.6 KB)

1 Like

Can you post a screenshot of your work too?

yep sorry i forgot…

You think you can try again. That one is unreadable. Maybe use the builtin screenshot tool.

ok hope this one is better. sorry again.

Cheers Michael

Is Dynamo action a parameter you added?

Hi john_pierson

Yes I use Dynamo Action as a instance text parameter to indicate to the detailing team that they need to change the user keynotes in that view to element keynotes.

I have tried it with the Default parameters and it still hasn’t worked.


@Batman86 Use (Object.Type) to check the type of Dynamo Action parameter is it Text or takes other type of data.

Hi fathygad

Forgive me not sure what you mean about the Object Type?
The Project Parameter takes a Text time of data.

ok cool i will have a go

the parameter type is a String type, but it is still not working…?

Hi all

I tried it with the default parameter “Title on Sheet” and it ran without any errors, but it still didn’t push into the view???

@Batman86 i tested on your script after creating shared parameter and it works fine i thing the problem is the type of date feeding the parameter

could you check plz is “Dynamo Action” Shared parameter is assigned for views.
of course if u could share a RVT sample it will be better.

thanks for that.
very interesting that its working on your end…
Here is the image of the parameter i am using.
I would normally give you the RVT but its a project file…

I got it to work once but then i try and run it again with different text it didn’t work?

Second time running the script