Can Explicit Custom Nodes be used inside DynamoSandbox.exe?

Pretty simple question to start. I’ve made an ECN following this tutorial:
Dynamo Unchained 2

That tutorial will give you two dlls: Functions and HelloUI. I can import Functions as a Zero Touch Node (ZTN) no problem in Sandbox The reason to use Sandbox is to reduce start up times of opening Revit, then opening Dynamo within it, as the dlls get locked. Sandbox is much faster for testing.

The second part imports fine in Dynamo for Revit. However, Sandbox will exit without any errors along the way (even if you attach to it and monitor the output). Lately, Sandbox would import the ECN into the menu, but as soon as I drag it out of the menu and into the graph work area, Dynamo crashes, and I get this inside Visual Studio:

The program '[19660] DynamoSandbox.exe: Managed (v4.0.30319)' has exited with code -2147483645 (0x80000003).

I’m beginning to suspect that ECNs are Dynamo for Revit specific? Can you use ECNs in Sandbox?

Have just tried other Sandbox versions, same result as above:

they definitely work in sandbox -
in visual studio goto exception settings and enable breaking on all exceptions - even handled ones, attach to sandbox - it’s extremely rare for an exception not to be catchable by the debugger - even if it can’t usually be caught.

how are you loading the nodes, as a package? If so make sure your package loading paths are in a clean state - ie the zt assembly is not being loaded from your package and also from directly from package paths.

take a picture of your bin folder if this is a package.

I also dont know how updated dynamo unchanined is, but you can try:

Thanks for pointing me to those examples.

I’ve reverted to just using ZT nodes for now. I think they have enough functionality for me, for the time being.