BIMOne.GoogleSheets package. Get.GoogleSheetsInGoogleDrive operation failed

Hi, there!
Thanks to @vincent.cadoret for BIMOne.GoogleSheets

I set up the console for my API, generated “Credentials.json” and imported them to the mentioned folder.
Everything as it is explained in the documentation.

It does not work for me so far. What should I do next?

Hi @s.semashka, can you give it another try today? Sometimes it takes a little while for Google’s systems to sync up the permissions. If it still doesn’t work, I’m wondering if Google has made breaking changes to the formatting of the credentials file…

Hi, @vincent.cadoret
Thank you for your reply.
I run the script today, and unfortunately, it is still not working.

@s.semashka What version of Revit / Dynamo are you using? I see you are in the 2.2 folder… is that the correct folder for the version of Dynamo you are running the script in? Is it possible that the credentials file is in the folder for the wrong version (it’s happened to me before…)?

@vincent.cadoret, thank you for your reply.
I believe that it is the right folder according to the version.
Dynamo-Revit

@s.semashka I still think that it’s because it’s not finding the credentials file.

Here is the code that creates the path to the credentials file:

static string assemblyPath = Path.GetDirectoryName(Assembly.GetExecutingAssembly().Location);
static string credentialsPath = Path.Combine(assemblyPath, @"…\extra\credentials.json");

It gets the path relative to the currently executing assembly (aka current version of Dynamo that is running). It goes back up one folder from the DLL and then back into the “extra” folder.

What version of Revit are you running this in?

Dear @vincent.cadoret, sorry for the late reply.
I double-checked it - the credentials.json file seems to be in the right place.
I am using the Dynamo in the Revit 2020.1.
Does the BIMOne.GoogleSheets package work on your computer?

It is working for me, however 2020.1 is outdated, you should be on 2020.2.2 and then it should show this Dynamo version:
image

Can you try updating to see if that helps?

@vincent.cadoret thank you for your reply.
Before I update to Revit 2020.2 or 2021 could you take a look at my Google console?
Maybe this can be the source of the problem?