Adjusting levels - Data-shapes

I came back to this script today and tried to setup a Data-Shapes UI. It’s not working. I tried adjusting levels because that was an issue I have had in the past with that package, but that didn’t work and I can’t seem to figure out what is the issue.
I tested it compared to the way it was setup originally and it looks like it is a levels issue, but when I adjust the levels it doesn’t help. How else can you adjust the level selection?



Can almost guarantee it’s a Python iteration issue. Can you share the python code as well as what you’re trying to get it to achieve?

Here is the file so you can check out the python script. The script is one that @john_pierson originally put together.
Viewport Title Alignment.dyn (50.0 KB)

Just needs a list.flatten as my python was expecting a flat list and data-shapes outputs a nested list


That worked.

I was messing around with data-shapes on this script a while back and was running into this issue and I would swear I tried List.Flatten and I couldn’t get it to work. That’s why I hadn’t tried it again this time.

Anywho, it works and that’s all that matters. Thanks!

1 Like