Adding levels with dynamo


#1

In the recent Vasari talk (#29), Zach showed an example of adding levels at an increment. I can do this part. Then he added a level 3ft. above every incremental level, which I'm having trouble doing. As far as I can see, I have everything exactly as he shows it on his desktop, but I'm getting an error under the 'Add' node: 'Malformed addition argument'


Under the console, I'm getting this:


System.Exception:
Malformed 'addition arg': ((10 22 34 46 58 70 82 94 106))
at Dynamo.FScheme.malformed[a](String n, Value e)
at Dynamo.FScheme.op'@364-1.Invoke(Double a, Value _arg1)
at Microsoft.FSharp.Collections.ListModule.loop@144-20[T,TState](FSharpFunc`3 f, TState s, FSharpList`1 xs)
at Dynamo.FScheme.math0(FSharpFunc`2 op, String name, Double start, FSharpList`1 exprs)
at Dynamo.FScheme.Add@378-1.Invoke(FSharpList`1 exprs)
at Dynamo.Nodes.dynBuiltinFunction.Evaluate(FSharpList`1 args)
at Dynamo.Nodes.dynNodeWithOneOutput.Evaluate(FSharpList`1 args, Dictionary`2 outPuts)
at Dynamo.Nodes.dynNode.__eval_internal(FSharpList`1 args, Dictionary`2 outPuts)
at Dynamo.Nodes.dynNode.<>c__DisplayClass1c.<evaluateNode>b__17()




I'm just getting started with Dynamo, so I'd really appreciate some help with this. Here's a screenshot and I've attached the .dyn file. I'm using the latest Vasari and Dynamo release. I've also tried Revit 2014, but get the same result.


Thanks.



#2

Yikes, that crash is nasty. We're on it.


Try this for Level creation. Make sure you right click on the level node and set "Lacing" to "Longest"



#3

I just downloaded a more recent version (0.3.4) and now I'm not getting that error. However, I can't get the number sequence node to repeat the level creation process. It'll create the first level (10') and the one above it (13'), then stop. So, no matter where the end of my number sequence is, it won't process the rest of the 'steps'.


Also, whenever I go to File>Save Image and click Save on the dialog box, Dynamo and Revit 2013 both crash, every time.



#4

Hi Jason,


Are you still seeing this error with the more recent builds?