Add Shared parameters to some families (Orchid package)

orchid

#19

The orchid package support any dynamo version later than 1.3.0+, that include the new 2.0.1+ range…


#20

I think the way i’m creating the list for the parameters is the root of the issue, sometimes I made it works and sometimes don’t I need to check how sensitive is Dynamo if a Node Crash, because I noticed sometimes I need to close the software and open it again or even jump the node and plugin directly to the close node becuase the families are still open in background.

Would be really helpfull if the node crash or something else the node can close the families automatic


#21

If you feed the nodes wrongly, then familydocuments will not be passed on… this will give errors since they are not being closed correctly. There is no other way around this than close Dynamo and Revit and start all over once more.

This is how it is, nothing to do about it.


#22

Hi erfajo,
i have a problem with your nodes, please see attached image,
i have download your packaged but is still not working
thanks for your help


#23

This is a migration problem… but I have made migration files, so why it don’t work is strange. However, it is easy to solve. Add the nodes once more and you are good to go. Sorry for the inconvenience.


#25

it looks like the file is missing. i have downloaded form your website the latest info… and it is still nor working.
any advise??
regards


#26

try using the executable installer --> https://github.com/erfajo/OrchidForDynamo
– and remember that Revit and Dynamo must be closed during installation.


#27

fixed!! thanks


#28

i cant understand the warning… could you help @erfajo??
i want do add the parameter in the froup “DATA”
Regards



#29

dont use lists for GroupName, Type and Group, try hover the “port” and you will see that the input does not take a list. It is only Document and ParameterName that takes lists as input!


#30

@erfajo so how do i add the rest of the information?
does not the node take the information from the txt file?


#31

If you write {"a"} then you send a list, if you change this to "a", then you send one item. You need to do the latter. However, if you send a list, then add list level to the input node!

The below is from a Dynamo 2.1.0 graph, please notice the differences


How to fix Invalid ParameterType-Error in Project.CreateProjectParameter
#32

@erfajo lets say that i want two cases, add only one parameter to som families in a folder, path added in “directory path”, i have deleted the “brackets” and i have only add “a” and i still have the same warnings (picture attached)


if i want to add some parameters in some families, do i have to add {a} ??


#33

Please upload your family file, shared parameter file and dynamo file? … this looks very strange.

One thing will go wrong, and that is your “Parameter Group”, this is not a valid feed!


#34

please, see attached files
test.txt (548 Bytes)
Plenum.rfa (336 KB)
Add Share Parameter test.dyn (8.9 KB)


#35

just by looking at the SP file… then I think your error is the feed… try this

//Parameter name
"a";
//SP Parameter group
"test";
//SP Parameter type
"Text";
//Parameter group
"PG_DATA";

#36

@erfajo thanks for you help, but unfortunately i still have the same problem.
have you tried in your computer?
it is weird, but something is wrong and i dont know what


#37

"TEXT" need to be "Text", but I noticed one other thing… your file is a Revit 2016 file. I dont support Revit 2016, only from 2017 and above. I think most packages do that and this goes also for dynamo in generel.


#38

Hi Erik. Thank you for creating this routine and your Orchid nodes package. I was just wondering if the FamilyDocument.AddSharedParameter node could incorporate an Input using the same line of thought for the Tool Tips. We know that once a shared parameter is created, there is no way editing them to incorporate the Tool Tips. I know that in Revit 2018 when they are brought into a new project one can do it but not in the previous versions. Is that possible? Please! I thank you beforehand for your help and attention.


#39

Please read this… and lets talk elsewhere