Adaptive 3Point on curve issue


#1

Hello everyone,
I’m tryng to model a RailTrack. For rail I use an Adaptive 3p family with a profile repated, for path I use a CAD file with 3D Poly. So with Bimorph node I import the information for paths.
The problem is that in some parts the family is not positioned correctly. Sometimes it is rotated, sometimes there are only the profiles and not the solid track.
I tried to move the adaptive points in the family and I do not get errors, and at the end of the Dynamo routine I do not have warning messages.
I tried (in adaptive family) to transform the path curves into a model and manually place the family but I have the same problem.
I tried to export the coordinates in Excel of the 3D poly vertices and import them into Dynamo but I have the same problem.
I have tried all the combinations of vertices orientation of the adaptive points but I have the same problem.
I saw that the curve starts with incorrect normals. I tried to change them but the problems increase.
Where am I doing wrong?
I attach the images,the graph and the family hoping someone can help me.
Thanks in advance.
Simone.

Rail_3P_Repeat.rfa (472 KB)


#2

can you post the DYN? Does the DYN give you any errors? If so please expand the errors and post.


#3

Hi Tom,
no, Dynamo doesn’t get any errors…Only models with wrong orientation.
I attach the DYN. and the DWG.
Thank you.
X_RailPath_CAD.dwg (126.6 KB)
RailTrack_from.CAD.Path_.rvt.dyn (120.5 KB)