3D Preview with Intel UHD Graphics

Hello everyone,
this problem has already poped-up in the forum:
3D preview doesn’t work in Dynamo

I’ve checked some issues here and i’m quite sure that the lack of dedicated graphic card is here to blame…

I have only Intel UHD Graphics 620

Does anyone know what kind of settings or other magic can help in here?

thanks a lot in advance!

Regards,
Jakub

None which I have seen. A dedicated card (not the intel chip which sucks power from the processor) is a system requirement.

After installing Dynamo Studio I got back 3D preview
I’ve done some other changes before as well… e.g. set the highest performance of graphics for Revit (windows settings) or adding DynamoForRevit path in System Variables

anyway, I think that the problem lays in software rather then in hardware

I had a similar problem with my old HP laptop, a while ago though, around when color was being introduced into Dynamo. It had a AMD Radeon-Intel switchable graphics card with very poor driver support from HP (nothing after 2011). Apparently I couldn’t install drivers from AMD, I tried some 3rd party drivers which never really helped and the machine became unstable.

So I was just stuck at an old version of Dynamo till I eventually replaced it with a new machine (Nvidia).

I think graphics drivers also play some role here.

1 Like

Hello Jakub,

Did you get back 3d preview in Revit dynamo? or only through dynamo studio?
Could you please let me know how did you do it (the windows settings and the system variables). I’m having the same problem with my lenovo 920 (only uhd 620). Anyway I really appreciate your help.
Thanks!

The intel card does not have the capacity to generate geometry preview.

@JacobSmall
I really don’t think that this is a graphic card capacity problem…
Of course dedicated Graphic Cards have bigger power and Dynamo works smoothier using it.
But somehow I was able to restore 3D Preview on my machine with Intel graphic card, even though the resolution is poor. It is still there!
Complete lack of 3D preview lays in the software, not hardware.

@amajzoub
Yes, I have a 3D Preview in Dynamo. Installing Dynamo Studio just provided some files (i could write here ‘something’, because I honestly don’t know what exactly), that lacked in ‘normal’ Installation (which comes with Revit). Additionally I have done some other changes.
I’m at work currently, I will check my private machine when i come home and come back to your problem later on.
It was a while ago but i’ll try to recall all the steps… i hope it will work for you as well.

Regards

Thank you for sharing your solution. I had same problem, but it was solved by installing Dynamo Studio same as you. 3D preview is now available in Dynamo of Revit 2020.

I use Lenovo think book 13s laptop with Intel UHD graphics 620( No Nvidia graphic)

I tried these things below, but they were not solution.

1, Reinstalling Revit 2020
2, Installing Dynamo Sandbox
3, Update Intel UHD 620 driver(my current Ver. is 26.20.100.7323)

I suppose that’s a kind of bug of Dynamo in Revit 2020…

That’s an incorrect statement. Any graphics card that supports DirectX10 (Shader Model 4.0 or greater) and has recent drivers installed should be able to display the background preview. That means that intel’s integrated graphics as far as HD2000 should be able to run it (albeit not very fast):

I’m currently using a lenovo x230 with HD4000 graphics that’s probably 6 years old by now and the background preview works just fine. I’ve also had no problems on a bootcamped mackbook air with HD5000 graphics

Dynamo 2.0.x:

Dynamo 2.6 alpha:

Mind you this is only the case for right now and it’s not guaranteed going forward. The Helix toolkit version that’s distributed with Dynamo is quite old and the team is planning on updating it:

My recommendation is to download your drivers only from intel.com and never use the drivers provided by the laptop ODM. Those are most often than not outdated, incompatible with newer software releases and riddled with security holes.

3 Likes

everything @Dimitar_Venkov said - also, I recommend installing dx from here:
https://www.microsoft.com/en-us/download/details.aspx?id=8109

even if you already have a newer dx.

I have seen issues with intel hd cards, but it’s never been clear it’s actually the chipsets or just a missing dx/driver/hd accel situation. Helix is old enough at this point, it may be a bug with how sharpdx or helix enumerate graphics cards.

1 Like

Its likely to be caused by laptop power management. If the Intel graphics cards are run on economy/low power settings, 3D preview is disabled. I discoved this a while back when I put my laptop on economy and noticed the background preview would not display. Just my 2 cents.

This was the case for me. I went into Graphics Settings in windows 10, not Nvidia, and set performance settings to max here. See image